Wir werden häufig gefragt, ob unsere Plugins und Themes mit bestimmten PHP Versionen kompatibel sind. Im folgenden geben wir Ihnen einen umfassenden Überblick. Grundsätzlich gilt, dass Sie immer eine zur PHP Version passende Version des ionCube Loaders benötigen, um alle Plugins aus dem Shopware Store verwenden zu können. Falls Sie nicht wissen, wie Sie die PHP Version einstellen, wenden Sie sich am besten direkt an Ihren Hoster. Dieser kann Sie hierbei am kompetentesten unterstützen. Es ist zusätzlich zu empfehlen, dass Sie einen technischen Ansprechpartner (z.B. eine Agentur oder einen Freelancer) zur Hand haben, der Sie unterstützen kann.


PHP 5.6

Dies ist die Version, die Shopware mindestens voraussetzt. PHP 5.6 ist im Vergleich zu neueren Versionen allerdings vergleichsweise langsam in der Ausführung. Verwenden Sie diese Version nur, wenn diese zwingend für ein bestimmtes Plugin oder Skript benötigt wird.


PHP 7.0

PHP 7.0.x bietet zwar eine gute Performance, gehört mittlerweile jedoch bereits zu den älteren Versionen. Alle Plugins und Themes von uns sind mit PHP 7.0 kompatibel. Verwenden Sie diese Version nur bis Shopware 5.4.x und wenn Sie durch den ionCube Loader verschlüsselte Plugins einsetzen.


PHP 7.1 und PHP 7.2

Für diese Versionen funktioniert der ionCube Loader nicht in Kombination mit den verschlüsselten Plugins aus dem Shopware Store. Die Verschlüsselung von Plugin entfällt jedoch seit Shopware 5.5. Verwenden Sie diese Versionen, wenn Sie Shopware 5.5.x einsetzen.