We were frequently asked, if our plugins and Themes are compatible with certain PHP versions. In order to apply all Shopware plugins, you always need the corresponding version of ionCube Loader for each PHP version you are using. In case you need assistance with the configuration of the PHP version or with the ionCube Loader, please contact your host. For your convenience, please find below an overview on different PHP versions and recommendations.


PHP 5.6

PHP 5.6 fulfills the basic requirements of Shopware. Compared to later versions it is relatively slow-paced and should only be used for plugins or skripts which depend on it.


PHP 7.0

PHP 7.0 is the ultimate version in terms of high-end performance and compability as all plugins and Themes are compatible with this version.


PHP 7.1 and PHP 7.2

For these versions, the ionCube Loader does not perform in combination with the encrypted plugins from Shopware yet. As a lot of plugins are encrypted, we recommend not to use these versions yet.